Loss of service for customers in Oundle

Incident Report for Zzoomm Full Fibre Broadband

Resolved

The issue affecting customers in Oundle is resolved.
Posted Jul 20, 2026 - 12:49 BST

Investigating

We are investigating an issue affecting customers in Oundle
Posted Jul 20, 2026 - 10:46 BST
This incident affected: FullFibre Network.