The service interruption that affected a small number of customers is now resolved. Apologies for any internet connectivity interruption you may have experienced this afternoon.
Posted May 13, 2026 - 16:04 BST
Investigating
We're currently aware of an Incident that is causing Service Disruption, we're currently investigating and will provide further information once available.
Posted May 13, 2026 - 15:13 BST
This incident affected: Live Full Fibre Broadband Networks (Bewdley area network status, Cannock area network status, Chapeltown area network status, Codsall area network status, Congleton area network status, Crewe area network status, Easingwold area network status, Great Ayton network status, Henley area network status, Hereford area network status, Northallerton area network status, Northwich area network status, Penistone area network status, Richmond area netework status, Sandbach area network status, Sandhurst area network status, Sherbourne area network status, South Elmsall area network status, Stokesley area network status, Tadcaster area network status, Thirsk area network status, Winsford area network status, Womborne area network status, Middlewich area network status).