Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 00:00 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 24, 2025 - 12:24 GMT
Scheduled
We're carrying out essential maintenance on our network to keep your broadband running smoothly. This means a brief service interruption of around 15 minutes in the early hours of Tuesday 25th March 2025 while we upgrade key equipment in your area.
Expected downtime: A single short service interruption (around 15 minutes) within this time window.
What do I need to do?
Please do not switch off your Zzoomm equipment during this time.
If you have trouble getting back online after 05:00, simply restart your Zzoomm Hub.
Thanks for your patience while we make these improvements!
The Zzoomm Team
Posted Mar 24, 2025 - 12:21 GMT
This scheduled maintenance affected: Live Full Fibre Broadband Networks (Crewe area network status, Winsford area network status).