Unplanned Outage - Crewe
Incident Report for Zzoomm Full Fibre Broadband
Resolved
This incident has been resolved. Please restart your router (only).

Thanks,

Zzoomm.
Posted Oct 19, 2024 - 16:20 BST
Investigating
We are currently investigating this issue.
Posted Oct 19, 2024 - 16:06 BST
This incident affected: Live Full Fibre Broadband Networks (Crewe area network status).