Service disruption

Incident Report for Zzoomm Full Fibre Broadband

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 13:51 GMT

Investigating

We are aware and so sorry some of you may experiencing service disruption. Engineers are investigating the issues to restore service but unfortunately at this stage we don’t know when that will be. We will keep this page updated as things progress. Once again, please accept our apologies for this disruption to your service.
Posted Mar 26, 2025 - 11:30 GMT
This incident affected: Live Full Fibre Broadband Networks (Northwich area network status).