Loss of Internet Connectivity for some customers in Richmond area

Incident Report for Zzoomm Full Fibre Broadband

Resolved

Services have been resolved for customers in the Richmond area.

Thank you for your patience whilst we fixed this issue.
Posted Jun 11, 2026 - 17:21 BST

Identified

Engineers are en route to Richmond to replace optical equipment in a street cabinet to restore service to customers without internet connectivity.

Service is expected to be restored by 19:00, Thursday 11th June 2026.
Posted Jun 11, 2026 - 14:05 BST

Investigating

We are currently investigating this issue.
Posted Jun 11, 2026 - 13:14 BST
This incident affected: Live Full Fibre Broadband Networks (Richmond area netework status).