Customer Care telephone lines out of service
Incident Report for Zzoomm Full Fibre Broadband
Resolved
This incident has been resolved.
Posted Jan 17, 2022 - 11:41 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 17, 2022 - 11:00 GMT
Investigating
The customer care telephone lines are currently out of service. Engineers are investigating. Customers are advised to contact the Care team via email at help@zzoomm.com or by webchat from our website at www.zzoomm.com
Posted Jan 17, 2022 - 10:48 GMT
This incident affected: Customer Care Telephone lines.