Customer Care telephone lines out of service
Incident Report for Zzoomm Full Fibre Broadband
Resolved
Customer care telephone lines are now operational again. We apologise for any inconvenience caused.
Posted Jan 10, 2022 - 22:11 GMT
Update
We are continuing to investigate this issue.
Posted Jan 10, 2022 - 18:22 GMT
Investigating
The customer care telephone lines are currently out of service. Engineers are investigating. Customers are advised to contact the Care team via email at help@zzoomm.com or by webchat from our website at www.zzoomm.com
Posted Jan 10, 2022 - 18:22 GMT
This incident affected: Customer Care Telephone lines.